Błąd vQmod w OpenCart – PHP Parse error: syntax error, unexpected ‚;’ in

 

PHP Parse error:  syntax error, unexpected ';' in /var/www/upload/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php on line 34
PHP Parse error:  syntax error, unexpected ';' in /var/www/upload/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php on line 34
PHP Parse error:  syntax error, unexpected ';' in /var/www/upload/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php on line 41
PHP Parse error:  syntax error, unexpected ';' in /var/www/upload/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php on line 92
PHP Parse error:  syntax error, unexpected ';' in /var/www/upload/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php on line 104
PHP Parse error:  syntax error, unexpected ';' in /var/www/upload/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php on line 142
PHP Parse error:  syntax error, unexpected ';' in /var/www/upload/vqmod/vqcache/vq2-system_storage_modification_system_library_config.php on line 23
PHP Parse error:  syntax error, unexpected ';' in /var/www/upload/vqmod/vqcache/vq2-system_storage_modification_system_library_language.php on line 35

Należy zmodyfikować plik vqmod\xml\vqmod_opencart.xml

<?xml version="1.0" encoding="UTF-8"?>
<modification>
    <id>VQMOD CORE FOR OPENCART - DO NOT REMOVE</id>
    <version>1.4.x and above</version>
    <vqmver required="true">2.6.0</vqmver>
    <author>vqmod.com</author>

    <file name="system/startup.php,admin/controller/extension/*.php,system/library/template/*.php">
        <operation error="skip" info="For non OCMod includes/requires">
            <search position="replace" regex="true"><![CDATA[~(require|include)(_once)?\((?!VQMod::modCheck\()(?!modification\()([^)]+)~]]></search>
            <add><![CDATA[$1$2(\\VQMod::modCheck($3)]]></add>
        </operation>
        <operation error="skip" info="For OCMod includes/requires - OPERATION MUST BE AFTER NON OCMOD INCLUDES/REQUIRES OPERATION">
            <search position="replace" regex="true"><![CDATA[~(require|include)(_once)?\((?!VQMod::modCheck\()modification\(([^)]+)~]]></search>
            <add><![CDATA[$1$2(\\VQMod::modCheck(modification($3), $3]]></add>
        </operation>
    </file>

    <file name="system/engine/*.php,system/library/*.php">
        <operation error="skip" info="For non OCMod includes/requires">
            <search position="replace" regex="true"><![CDATA[~(require|include)(_once)?\((?!VQMod::modCheck\()(?!modification\()([^)]+)~]]></search>
            <add><![CDATA[$1$2(\\VQMod::modCheck($3)]]></add>
        </operation>
        <operation error="skip" info="For OCMod includes/requires - OPERATION MUST BE AFTER NON OCMOD INCLUDES/REQUIRES OPERATION">
            <search position="replace" regex="true"><![CDATA[~(require|include)(_once)?\((?!VQMod::modCheck\()modification\(([^)]+)~]]></search>
            <add><![CDATA[$1$2(\\VQMod::modCheck(modification($3), $3)]]></add>
        </operation>
    </file>
</modification>

 

Add Comment

Required fields are marked *. Your email address will not be published.